aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac7bfb9..60b216c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,10 @@ AC_ARG_ENABLE([threads],
AS_IF([test "x$enable_threads" = "xyes"],
[
AX_PTHREAD
+ LIBS="$PTHREAD_LIBS $LIBS"
+ CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+ CC="$PTHREAD_CC"
+
AC_DEFINE([ENABLE_THREADS], [1], [Enable thread awarness])
],
# else