aboutsummaryrefslogtreecommitdiffstats
path: root/pkg/gentoo/librb-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'pkg/gentoo/librb-1.0.0.ebuild')
-rw-r--r--pkg/gentoo/librb-1.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkg/gentoo/librb-1.0.0.ebuild b/pkg/gentoo/librb-1.0.0.ebuild
new file mode 100644
index 0000000..8d6aae2
--- /dev/null
+++ b/pkg/gentoo/librb-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="ring buffer c library with posix-like read/write interface and thread awarness"
+HOMEPAGE="http://librb.kurwinet.pl"
+SRC_URI="http://distfiles.kurwinet.pl/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable threads threads)
+}
+
+src_install() {
+ default
+}